Coinbase

Author Topic: Upgrading problem  (Read 2936 times)

0 Members and 1 Guest are viewing this topic.

Offline Cold Shot

  • Newbie
  • *
  • Posts: 6
    • Email
Upgrading problem
« on: July 16, 2007, 03:46:54 am »
Yesterday I decided to see what could be done about upgrading to the latest version of SMFads so that I can make use of various changes, such as the no ads for admin option, as well as stopping ads between posts looking like posts.

I set out by uninstalling the Ad module on my test site (which is running 1.1RC3). It looked like it was gone. I then installed version 2.3 of the ad module and everything seemed to go fine. I tried testing out some ads and I got the problem with the duplicated ads.

I checked all the support threads here about what to do and I have managed to eradicate most of the duplicate code, yet there is one piece of code that I can't find in any of the templates and its driving me nuts.

If I select the option to display ads between posts, I am getting a duplicate - it's picking up the old code as well as the new one. I can't find this duplicate code anywhere. Please can someone help? I'm using the default theme and have edited those templates.

Also, I am rather reluctant to do this upgrade on my live site if its going to involve this much effort. Why did the package manager on the test site not completely remove all the code from SMF ads? Is this a bug?

Offline bigguy

  • Support
  • Elite Member
  • *
  • Posts: 1518
    • SMF Helper
Re: Upgrading problem
« Reply #1 on: July 18, 2007, 06:04:11 pm »
No it is not a bug and it should have removed it all. for some reason it did not. Check your index.php file and see if there is duplicate code there, if there is remove it as well.

Offline Cold Shot

  • Newbie
  • *
  • Posts: 6
    • Email
Re: Upgrading problem
« Reply #2 on: September 06, 2007, 03:01:47 am »
Sorry to bug you guys about this again, but I am still having issues with SMF Ads and trying to upgrade my forum from RC1.3 to the latest version. I tried to uninstall the Ads module from my test site and it failed three tests while doing this from the Admin control panel. These files failed the test:

default/index.template.php
default/Display.template.php
default/MessageIndex.template.php

I proceeded with the uninstall on my test site anyway and encountered the following error when trying to re-enter the site:

"Fatal error: Call to undefined function: show_topofpageads() in /home/nikongea/public_html/smftest/Sources/Load.php(1702) : eval()'d code on line 136"

I can't find that function anywhere in that file. Can you help? We really need to move ahead with our upgrade but can't do this until we get this Ad mod removed. If I leave it in the upgrade doesn't work.

TIA

Oh, link to the test site is: http://nikongear.com/smftest/

Offline Cold Shot

  • Newbie
  • *
  • Posts: 6
    • Email
Re: Upgrading problem
« Reply #3 on: September 06, 2007, 11:52:37 pm »
Bump.

Anybody know why I can't uninstall this mod from the forum? Please help!

Offline jerm

  • Support
  • Elite Member
  • *
  • Posts: 726
Re: Upgrading problem
« Reply #4 on: September 09, 2007, 03:58:20 pm »
The error you are getting is located in index.template.php

The duplicate post stuff is found in Display.template.php

SMF Ads Support Forum

Re: Upgrading problem
« Reply #4 on: September 09, 2007, 03:58:20 pm »
.