Coinbase

Author Topic: index.php permission error  (Read 2514 times)

0 Members and 1 Guest are viewing this topic.

Offline bermudasucks

  • Newbie
  • *
  • Posts: 2
    • Email
index.php permission error
« on: April 22, 2007, 12:43:37 am »
Hi,

I've got v. 2.3 installed on my 1.1.2 forum but I'm running into a problem creating ads.  When I try to create an Adsense or AdBrite ad (Add button on the Add Ad page), I get the following message:

Forbidden
You don't have permission to access /forum/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
--------------------------------------------------------------------------------
Apache/1.3.37 Server at www.bermudasucks.com Port 80


I've used the Packages / Options / Make all files writeable; then verified that everything, including /forum/index.php is 777.

The weird thing is, if I edit the Content field to just a test text string (test or <test>), it works ad I can see the 'ad' as expected.  If I use only <script> I get the error above.

Thanks,
Will McLay

Offline bermudasucks

  • Newbie
  • *
  • Posts: 2
    • Email
Re: index.php permission error
« Reply #1 on: April 22, 2007, 03:39:37 pm »
I found this solution on the SMF forum.

Adding the following to .htaccess fixed the error:

<IfModule mod_security.c>
   # Turn off mod_security filtering.  SMF is a big boy, it doesn't need its hands held.
   SecFilterEngine Off

   # The below probably isn't needed, but better safe than sorry.
   SecFilterScanPOST Off
</IfModule>

Offline bigguy

  • Support
  • Elite Member
  • *
  • Posts: 1518
    • SMF Helper
Re: index.php permission error
« Reply #2 on: April 26, 2007, 09:36:51 am »
Glad it is fixed for you. Sorry for the wait on the reply.

SMF Ads Support Forum

Re: index.php permission error
« Reply #2 on: April 26, 2007, 09:36:51 am »
.