Coinbase

Author Topic: Manual Install SoftMC Theme  (Read 5294 times)

0 Members and 1 Guest are viewing this topic.

Offline devnet

  • Jr. Member
  • **
  • Posts: 23
    • Email
Manual Install SoftMC Theme
« on: December 26, 2006, 09:40:39 pm »
Hiya

Got this working fine with my default theme.  Now I'm trying to manually install this on the SoftMC Theme:
http://themes.simplemachines.org/index.php?lemma=166

So I've tried to go through about 5-6 times but there are key things missing for this to install.  I've attached the vanilla php files to this post and will attach how I altered them in my second post...

I cannot get the template to render though when using my alterations.  Many of the elements inside the XML file aren't present in that theme...is there a common place I could put each alteration or a standard 'rule of thumb' to use when manually installing?  I'm at a loss here...I'm not a complete php moron so I know enough to find the elements that need altered but it still isn't working.  Any direction given are appreciated.

As stated, vanilla SoftMC files needing alteration are attached...second post to contain my manual edits.

Offline devnet

  • Jr. Member
  • **
  • Posts: 23
    • Email
Re: Manual Install SoftMC Theme
« Reply #1 on: December 26, 2006, 09:41:22 pm »
As stated...my manually altered files (trying to install the admod :D )

Offline thegame11

  • Newbie
  • *
  • Posts: 1
Re: Manual Install SoftMC Theme
« Reply #2 on: December 28, 2006, 04:30:11 pm »
Template Parse Error!
There was a problem loading the /Themes/SoftMC_Blue/index.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in .../Themes/SoftMC_Blue/index.template.php on line 177

168:             current_header_ic = mode;
169:          }
170:       // ]]></script>';
171:
172:    echo '
173: </head>
174: //Display ads on the top of the page
175:    $ads = show_topofpageAds();   
176:    if(!empty($ads))

177:       if($ads['type']==0)

178:          echo $ads['content'];
179:       else
180:          eval($ads['content']);   
181:    unset($ads);


Offline bigguy

  • Support
  • Elite Member
  • *
  • Posts: 1518
    • SMF Helper
Re: Manual Install SoftMC Theme
« Reply #3 on: December 28, 2006, 04:42:21 pm »
Try this:

Offline devnet

  • Jr. Member
  • **
  • Posts: 23
    • Email
Re: Manual Install SoftMC Theme
« Reply #4 on: December 28, 2006, 09:04:09 pm »
Works great until you enter into a post..

I have the ad management module set to post a half banner on post 1 and post 7.  When I enter into a forum, I get the following error:

Code: [Select]
Template Parse Error!
There was a problem loading the /Themes/SoftMC_Blue/Display.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.
syntax error, unexpected '<'

So the front page is fine, entering into a forum is fine, but entering into a post causes the error above.

Offline bigguy

  • Support
  • Elite Member
  • *
  • Posts: 1518
    • SMF Helper
Re: Manual Install SoftMC Theme
« Reply #5 on: December 29, 2006, 04:01:42 pm »
Well, the only thing I could figure out is to take this out after the last edit in the Display.template.php:

Code: [Select]
<tr><td style="padding: 0 0 1px 0;"></td></tr>
</table><br />';
{

I honestly do not know what that is going to look like but it produces no errors when being debugged.PLEASE backup before trying this. It's not going to hose your whole forum or nothing but like I said I don't know what taking that little bit of code out will make things look like.

Offline dklassen

  • Jr. Member
  • **
  • Posts: 27
Re: Manual Install SoftMC Theme
« Reply #6 on: December 31, 2006, 02:09:15 pm »
Looking to run TP 0.9.7 and SMF 1.1.1 using the SoftMC theme and the Ad mod. Does anyone have a set of template files that will work already completed?

Thanks!

Offline devnet

  • Jr. Member
  • **
  • Posts: 23
    • Email
Re: Manual Install SoftMC Theme
« Reply #7 on: January 12, 2007, 01:56:23 pm »
That Did it :)

Don't know what you changed...but I have softMC running quite nicely with it.

Offline lonrot

  • Newbie
  • *
  • Posts: 8
    • Email
Re: Manual Install SoftMC Theme
« Reply #8 on: April 09, 2007, 02:09:41 pm »
Looking to run TP 0.9.7 and SMF 1.1.1 using the SoftMC theme and the Ad mod. Does anyone have a set of template files that will work already completed?

Thanks!

Same here, does anybody has the customized files of SoftMC_Blue to work with TP 0.9.8 and SMF 1.1.2?
Big Thanks!

Offline lonrot

  • Newbie
  • *
  • Posts: 8
    • Email
Re: Manual Install SoftMC Theme
« Reply #9 on: June 25, 2007, 06:04:24 pm »
Hi, well I have tried using this edit, but it didn't work, I'm using Tiny Portal + SoftMC on SMF 1.2. Remember that the Display.template is a little different in my case (check the attachment)

Thank you.

Offline bigguy

  • Support
  • Elite Member
  • *
  • Posts: 1518
    • SMF Helper
Re: Manual Install SoftMC Theme
« Reply #10 on: June 25, 2007, 06:37:19 pm »
I will try to get to this tonight.

Offline robin cracker

  • Newbie
  • *
  • Posts: 1
Re: Manual Install SoftMC Theme
« Reply #11 on: January 11, 2008, 12:26:25 am »
any news to use ad managmen in softblu,thanks

SMF Ads Support Forum

Re: Manual Install SoftMC Theme
« Reply #11 on: January 11, 2008, 12:26:25 am »
.