Author Topic: Strange display with ads installed  (Read 1871 times)

0 Members and 1 Guest are viewing this topic.

Offline cdntrucky

  • Newbie
  • *
  • Posts: 6
Strange display with ads installed
« on: February 17, 2017, 02:37:17 pm »
I recently had to move my SMF forum from a shared server to a VPS server. But in the migration process something got messed up. So this morning I made sure that SMF was at the most recent version (2.0.13). I then installed ad_mod_v3.2_SMF_v2-0. It gave no errors so I installed it after modifying all the needed php files.

So when I go into my Forum I basically get a Forum in a Forum. I am attaching a screen capture to show what I mean.

Can someone please assist me in what needs to be fixed?

Thanks.

Offline vbgamer45

  • Owner
  • Full Member
  • *
  • Posts: 106
Re: Strange display with ads installed
« Reply #1 on: February 17, 2017, 02:42:23 pm »
Run this query on your database
Code: [Select]
alter table smf_ads HITS HITS BIGINT NOT NULL default '0';

Offline cdntrucky

  • Newbie
  • *
  • Posts: 6
Re: Strange display with ads installed
« Reply #2 on: February 17, 2017, 02:49:28 pm »
No still getting the same issue.

It is still telling me that the database is at version 2.0.4. But I would have thought that applying the updates to SMF would have resolved that.

Offline vbgamer45

  • Owner
  • Full Member
  • *
  • Posts: 106
Re: Strange display with ads installed
« Reply #3 on: February 17, 2017, 02:59:28 pm »
That query should do it.

Offline cdntrucky

  • Newbie
  • *
  • Posts: 6
Re: Strange display with ads installed
« Reply #4 on: February 17, 2017, 03:01:58 pm »
Here is a more recent screen capture

Offline cdntrucky

  • Newbie
  • *
  • Posts: 6
Re: Strange display with ads installed
« Reply #5 on: February 17, 2017, 03:05:27 pm »
When I tried to run your SQL query, I got an error. Was "HITS" suppose to be in there twice? I deleted on of them and still got an error. So I just modified the field in phpMyAdmin.

Offline vbgamer45

  • Owner
  • Full Member
  • *
  • Posts: 106
Re: Strange display with ads installed
« Reply #6 on: February 17, 2017, 03:10:03 pm »
Yes because it is changing the column

Offline cdntrucky

  • Newbie
  • *
  • Posts: 6
Re: Strange display with ads installed
« Reply #7 on: February 17, 2017, 03:28:26 pm »
Not sure if you noticed on the screen capture, but when I install the Ad Manager the content of my Forum is in two places? How can installing the Ad Management do that? I realize I had to edit a bunch of php files before installing Ad Management. But seems so strange.

Any idea of what database structure changes are made in the different versions?

Offline cdntrucky

  • Newbie
  • *
  • Posts: 6
Re: Strange display with ads installed
« Reply #8 on: February 17, 2017, 03:39:00 pm »
I just realized that when they migrated my database over to the new server that I had two copies and I changed the field properties in the wrong database. So now it works properly.

Thank you SO much.

Offline vbgamer45

  • Owner
  • Full Member
  • *
  • Posts: 106
Re: Strange display with ads installed
« Reply #9 on: February 17, 2017, 03:44:21 pm »
Glad to help.

SMF Ads Support Forum

Re: Strange display with ads installed
« Reply #9 on: February 17, 2017, 03:44:21 pm »
.

 

.