Coinbase

Author Topic: Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?  (Read 15130 times)

0 Members and 1 Guest are viewing this topic.

Offline Gaz

  • Jr. Member
  • **
  • Posts: 11
Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?
« on: April 18, 2009, 11:07:24 am »
DOHHHHH !!!!

After hours of trying to get this mod to work on SMF 2.0 RC1 and weeks of reading this forum and the author's site looking for an answer, I realise now ....

.... the latest download file is called ad_mod_v2-3-4_SMF_vbeta4.zip

Note that file name ... it is v2.3.4 for SMF 2.0 Beta 4

It is NOT for RC1

However, despite that, I will post my issues just in case it helps the mod authors to bring the mod up to speed for RC1 any faster.

I have it installed all fine, and superficially working fine, on SMF 2.0 RC1 - all the menus and everything else are visible in admin and working.  For now I have set all user groups (including guests) to see all ads.

Now here's the issue - when setting up ads based on boards - example - board A covers topic A and there is an advert specifically for subject A, then to me this is an "ad match" and Ad A should be targeted at Board A.  With me so far?

OK - in Admin - Configuration - Ad Management - Add Ads ... there are three suitable options after choosing the board number for where to display this ad -

- Display ads on board index
   
- Display ads on message index
   
- Display ads on the post page
   
The help buttons describe where these positions are (rather badly in my opinion) but it is important to read the following to understand the problem I am getting with bugs in my install of Ad Management v2.3.4
How the help buttons describe the locations is -

- Board Index - on the main board area. This section is typically the root of the forum.
- Message Index - on the message index page. These pages are found within the boards, but are not the posts
- Post Page -  on the message page itself.

OK that's how the help buttons describe them, and in my opinion, they are completely wrong -

- Forum Index - This is the home page of the forum (i.e. /smf/index.php ) and the forum root - it displays the forum categories and the first level boards in those categories.
- Board Index - This is the BOARD or CHILD-BOARD LIST (not the forum root) and it displays (in a vanilla install) first the child-boards list/index, then the topics posted list/index for topics posted directly to the board number XXX, which is the current board being viewed.
- Message Index - is the list of topics in the current board XXX - whether that board is first or fortieth level down the heirarchy - the message index is displayed for every board on each and every board level, (at every heirarchy level), whether it has topics or not.  It is the second list, which follows the Board Index, on any board level page - the child-boards' Board Index being the first part of the page.
- - The combined Board Index and Message Index is the LEVEL Index / Board Page at any particular layer of the board and message heirarchy - it should be referred to as the Board Page.
- Message Page - is the TOPIC DISPLAY PAGE - where readers can read the messages that have so far been posted into an individual topic (note - in SMF they are referred to as "topics" - more commonly in other software, they are referred to as "threads").
- Post Page - by its very name can only ever have ONE post and by definition within the software, that means this is the page where you write and post your post.

Therefore the correct heirarchical naming convention should be -

- Forum Index - page containing the categories list
- - Category Index - page containing the first level boards (topics cannot be assigned to categories - only to boards)
- - - Board PAGE - page containing the Child-Board Index & current board-level topics
- - - Board Index - the child-board list that is part of the Board Page
- - - Message Index - the list of Topics that are posted into the current level board (whether it is first level or a child-board) - it is part of the Board Page (unless this board has NO child-boards, then the Message Index becomes the whole Board Page by default).
- - - - Topic Page - the page that displays all the posts within a topic/thread, whether it is only the OP, or whether it has many replies.
- - - - - Post Page - is the page where a user writes their post.

Note in the above heirarchy - an individual list of boards or topics is an "Index",
but a page containing multiple indexes, or a single topic's content, is a "Page".

Finally, here's my problem -

As I said at the top, everything is working fine except the following -

- Ads selected to display on the "message index" are displaying on the "topic page" (i.e. the page for reading a topic's posts and replies) - not the index list of topics claimed by the mod authors.
- Ads selected to display on the post page (i.e. the posts and replies within the topic according to the mod's author) NEVER display anywhere - not even on the post writing page.
- Ads selected to display on the Board Index NEVER appear anywhere, at any level of the heirarchy.

Example -
- At http://www.buildaskill.com/board/index.php/board,105.0.html is the board page for one of the child boards in one of my forums.  It has no child boards of its own, therefore the topic index becomes the whole of the board index.  According to the choices I have made in admin, there should be an advert below the first menu bar, and above the breadcrumb trail.  There is not.
However, if you enter any of the topics/threads in that board, you will see the advert that should have been one level up in the heirarchy.

These errors, and my structural comments above, indicate there is a severe naming mismatch between the core conventions used up to SMF 2.0 vBeta4, and the core naming in use within SMF 2.0 RC1, for the different levels of the forum heirarchy, from top home index, down through boards and child-boards, to individual topics and posts.

This I believe is why Ad Management v2.3.4 does not work fully with SMF 2.0 RC1 - not the mod author's fault at a code level (because they state v2.3.4 is for up to Beta4 only), but in terms of the admin help pop-ups, they also have some rewriting to do (feel free to copy from what I've typed above if it helps and saves you time).

Gaz

Offline Gaz

  • Jr. Member
  • **
  • Posts: 11
Re: Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?
« Reply #1 on: January 03, 2010, 01:14:35 pm »
In the last few days, I've upgraded my SMF 2.0 RC1.2 install to SMF 2.0 RC2

I also upgraded Ad Management from 2.3.4 to 2.3.6 which the SMF mods repository says is RC2 compliant.

The mod installed fine (no errors) but it still operates incorrectly as per my last post.

- No ads are appearing on the forum index at the root of the forum
- No ads are appearing on the category/board indexes - either at top of page, between child boards and topics. nor after last topic
    (they should be as per this example - http://www.smfads.com/forums/index.php?PHPSESSID=341cbcab974d65eb3aacaec80950224f&board=14.0 but are NOT appearing)
- Ads ARE appearing in the topic thread, in all the expected places set for the category/child-category topic index

There is either something seriously wrong with the mod, or SMF, or me - right now I don't know which.

Will someone PLEASE respond and help - it is 8 months since I first posted about this.

Thanks

Gaz

Offline ccbtimewiz

  • Sr. Member
  • ****
  • Posts: 326
    • Dream Portal
Re: Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?
« Reply #2 on: January 03, 2010, 01:45:26 pm »
Are you using a custom theme?

A custom theme requires manual template edits for this particular mod-- likewise I don't believe the mod author has updated the help pop-ups yet and I doubt they will be updated any time soon.

Offline Gaz

  • Jr. Member
  • **
  • Posts: 11
Re: Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?
« Reply #3 on: January 03, 2010, 02:03:51 pm »
Hi cc

Nope - I am using the default theme (and was doing so under RC1.0 / 1.1 / 1.2)

To be honest, although the package installs cleanly without errors, it has never fully worked for me going all the way back to mid-2007 (and I've updated SMF every time a new release has come out - so you can imagine how many versions this problem has persisted over).

---

I have spottered that Jeremy is trying to sell SMFads (mod and site) so I understand he's not going to be making any radical revisions to the package, however, I'd just like to get it working fully.

Thanks for answering

Gaz

Offline Gaz

  • Jr. Member
  • **
  • Posts: 11
Re: Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?
« Reply #4 on: January 03, 2010, 03:58:46 pm »
Digging into this more - remember this is SMF 2.0 RC2 using the default curve theme

I have an advert set to display under child boards on a particular board (that I'm using for this example) - that advert has never shown in almost two years of using the mod.


In BoardIndex_template.php ... after the long section starting with = // Show the "Child Boards
there is this code -

Code: [Select]

   //Display ads Between cats
   if (function_exists("show_category"))
   {
      $ads = show_category($category['id']);
      if(!empty($ads))
         if($ads['type']==0)
            echo $ads['content'];
         else
            eval($ads['content']);
      unset($ads);
   }


then it closes the table for the child categories and moves on to the next logical row of the page (posting icons etc).

There is NO code here for the " show underchildren " function - viewing page source confirms this, viewing the page in FireBug using FireFox also confirms this.  The install xml is therefore incomplete, and always has been based on my experience as a user.
This is from the install.xml file ov v2.3.6 -

Code: [Select]

<file name="$themedir/BoardIndex.template.php">
<operation>
<search position="after"><![CDATA[ // Show some statistics if stat info is off.]]></search>

<add><![CDATA[
//Display ads on the board index
if (function_exists("show_boardAds"))
{
$ads = show_boardAds();
if(!empty($ads))
if($ads['type']==0)
echo $ads['content'];
else
eval($ads['content']);
unset($ads);
}
]]></add>
</operation>

<operation>
<search position="before"><![CDATA[ echo '
</tbody>
<tbody class="divider">
<tr>
<td colspan="4"></td>
</tr>
</tbody>';]]></search>
<add><![CDATA[
echo '<tbody><tr><td colspan="4">';
//Display ads Between cats
if (function_exists("show_category"))
{
$ads = show_category($category['id']);
if(!empty($ads))
if($ads['type']==0)
echo $ads['content'];
else
eval($ads['content']);
unset($ads);
}
echo ' </td></tr></tbody>';
]]></add>
</operation>
</file>


As you can see, there is no code there to install the ad code for the function referenced in LoadAds.php as
   'show_underchildren' => $row['show_underchildren'],

Therefore it doesn't matter what we set in admin - that ad position is never going to work.  

I suspect the same is true of other non-functioning ad positions, including the welcome area position, which worked fine in 2.0 RC1.x but has disappeared in RC2

Please ask Jeremy to dig into this - we need answers on this, especially if he is abandoning the mod by selling it off.

Thanks
Gaz


p.s. - edit - I've just done more testing on the "between categories" position and it does not work either - no ads show up at all
« Last Edit: January 03, 2010, 04:07:54 pm by Gaz »

SMF Ads Support Forum

Re: Ads Management v2.3.4 & SMF 2.0 RC1 - root of the problem?
« Reply #4 on: January 03, 2010, 03:58:46 pm »
.