Coinbase

Author Topic: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues  (Read 14717 times)

0 Members and 1 Guest are viewing this topic.

Offline Jump1979man

  • Jr. Member
  • **
  • Posts: 25
SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« on: January 28, 2009, 06:08:00 pm »
Please see http://www.omahasportbikes.com and check out the welcome area where it should be...

I currently dont have any ads placed in this area due to the space being messed up.  Something with the space is messed up and I cant seem to figure out what it is exactly...I think its just missing something to close off the code but for the life of me I cant seem to figure it out.

The welcome area should look like it does on this forum http://www.mwmotorcycles.com

Anyone have any ideas?

This is the code in question
Quote
   // Otherwise they're a guest - this time ask them to either register or login - lazy bums...
   else
   {
      echo '
            <script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/scripts/sha1.js"></script>
            <form class="windowbg" id="guest_form" action="', $scripturl, '?action=login2" method="post" accept-charset="', $context['character_set'], '" ', empty($context['disable_login_hashing']) ? ' onsubmit="hashLoginPassword(this, \'' . $context['session_id'] . '\');"' : '', '>
               ' , $txt['login_or_register'], '<br />
               <input type="text" name="user" size="10" />
               <input type="password" name="passwrd" size="10" />
               <select name="cookielength">
                  <option value="60">', $txt['one_hour'], '</option>
                  <option value="1440">', $txt['one_day'], '</option>
                  <option value="10080">', $txt['one_week'], '</option>
                  <option value="43200">', $txt['one_month'], '</option>
                  <option value="-1" selected="selected">', $txt['forever'], '</option>
               </select>
               <input type="submit" value="', $txt['login'], '" /><br />
               ', $txt['quick_login_dec'];

      if (!empty($modSettings['enableOpenID']))
         echo'
               <br />
               <input type="text" name="openid_url" id="openid_url" size="25" class="openid_login" />';

      echo '
               <input type="hidden" name="hash_passwrd" value="" />
            </form>';
   }

   echo '
         </div>
';
                     echo '<div class="windowbg2 clearfix" align="right">';
                     //Welcome Ads
                     if (function_exists("show_welcomeAds"))
                     {
                        $ads = show_welcomeAds();
                        if(!empty($ads))
                        {
                           echo '<td class="windowbg2">';
                           if($ads['type']==0)
                              echo $ads['content'];
                           else
                              eval($ads['content']);
                        }
                        unset($ads);
                     }
                     echo '</div>';
               echo '



</div>
      
      <div id="news_section" class="titlebg2 clearfix"', empty($options['collapse_header']) ? '' : ' style="display: none;"', '>
         <form class="floatright" id="search_form" action="', $scripturl, '?action=search2" method="post" accept-charset="', $context['character_set'], '">
            <a href="', $scripturl, '?action=search;advanced" title="', $txt['search_advanced'], '"><img id="advsearch" src="'.$settings['images_url'].'/filter.gif" align="middle" alt="', $txt['search_advanced'], '" /></a>
            <input type="text" name="search" value="" style="width: 190px;" />&nbsp;
            <input type="submit" name="submit" value="', $txt['search'], '" style="width: 11ex;" />
            <input type="hidden" name="advanced" value="0" />';

   // Search within current topic?

In the install instructions it says to add the bold BEFORE this
Quote
echo '
         </div>

however it adds it AFTER and when I tried to add it before the site errors out....

Please help.  Thanks.


btw, this is in the default theme index.template file.

Offline ccbtimewiz

  • Sr. Member
  • ****
  • Posts: 326
    • Dream Portal
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #1 on: February 03, 2009, 01:59:49 pm »
This is confusing. Could you just attach your index.template.php file so I can fix it?

Offline defiant

  • Jr. Member
  • **
  • Posts: 20
    • Email
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #2 on: February 05, 2009, 09:34:43 am »
I've had this problem since beta 4 came out.  I'm now on RC1 and still have the issue.  I've attached my file but you'll note I haven't even put any add's in it yet but it's still screwed my theme up

Offline defiant

  • Jr. Member
  • **
  • Posts: 20
    • Email
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #3 on: February 06, 2009, 02:08:22 am »
Anyone ?

Offline ccbtimewiz

  • Sr. Member
  • ****
  • Posts: 326
    • Dream Portal
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #4 on: February 06, 2009, 01:33:05 pm »
I'll look at it in a few moments.

Offline defiant

  • Jr. Member
  • **
  • Posts: 20
    • Email
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #5 on: February 06, 2009, 03:51:58 pm »
I'll look at it in a few moments.
Anything ?

Offline Jump1979man

  • Jr. Member
  • **
  • Posts: 25
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #6 on: February 07, 2009, 11:44:58 am »
This is confusing. Could you just attach your index.template.php file so I can fix it?

Looks like defiant posted the file.  I am anxious to see what the solution is.  Thanks.

Offline defiant

  • Jr. Member
  • **
  • Posts: 20
    • Email
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #7 on: February 10, 2009, 05:46:20 am »
Are their any updates regarding this problem because it would be nice to have a compatilble version for 2.0 :)

Offline defiant

  • Jr. Member
  • **
  • Posts: 20
    • Email
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #8 on: February 19, 2009, 04:36:59 am »
Are their any updates regarding this problem because it would be nice to have a compatilble version for 2.0 :)
guess not

Offline defiant

  • Jr. Member
  • **
  • Posts: 20
    • Email
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #9 on: February 22, 2009, 07:15:40 am »
Would be nice to have some kind of update

Offline Jump1979man

  • Jr. Member
  • **
  • Posts: 25
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #10 on: April 09, 2009, 03:40:46 pm »
still no update..... >:(

Offline ccbtimewiz

  • Sr. Member
  • ****
  • Posts: 326
    • Dream Portal
Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #11 on: April 11, 2009, 10:47:06 pm »
I'm confused as to who is getting the support.

Where are two people asking for support with the same issue? Please don't hijack threads.

Locked.

SMF Ads Support Forum

Re: SMF Ads 2.3.4 and SMF 2.0 beta 4 Welcome area Issues
« Reply #11 on: April 11, 2009, 10:47:06 pm »
.

 

.