SMF Ads Support Forum

Support => General Support => Topic started by: Cast Away on March 23, 2007, 01:03:49 am

Title: Ads only show up to Admin,not guest or members
Post by: Cast Away on March 23, 2007, 01:03:49 am
Hello there!
I have SMF 1.1.2 and installed the ads mod(ad_mod_1-1-x_v2-3). I uploaded and installed it with the original theme. But the control panel didnt show up, so i installed it manually and changed to orange-lt theme with the modified files from here. Now the panel for ads are showing up. I added my code but only admin can see the ads. Can someone give me a guided walktrough on how to fix this problem??


Regards

Cast Away
Title: Re: Ads only show up to Admin,not guest or members
Post by: Cast Away on March 23, 2007, 07:15:43 am
I installed same version and theme here locally and installed the ads mod here. now i see that im missing that check box at top right corner under permissions.
Is it so i need to upload a file or do i need to install in on new??

Maybe take the files on my install here locally and upload to the server? Will it overwrite any topics,users etc??
Title: Re: Ads only show up to Admin,not guest or members
Post by: jerm on March 23, 2007, 12:39:22 pm
You are having a permission issue. Since you know how to install manually. Make sure these edits are done:
Code: [Select]
<file name="$sourcedir/ManagePermissions.php">
<operation>
<search position="replace"><![CDATA[ 'pm' => array(]]>
</search>
<add><![CDATA[ 'ad_manage' => array(
'ad_manageperm' => false,
),
'pm' => array(]]>
</add>
</operation>
</file>
Title: Re: Ads only show up to Admin,not guest or members
Post by: joepro on March 29, 2007, 06:18:43 am
So are you saying that in order for this mod to work I have to manually edit files???

Only the admin sees these ads.

Can you not produce a package that installs properly to work properly?
Title: Re: Ads only show up to Admin,not guest or members
Post by: geordie blue on April 03, 2007, 07:36:01 pm
You are having a permission issue. Since you know how to install manually. Make sure these edits are done:
Code: [Select]
<file name="$sourcedir/ManagePermissions.php">
<operation>
<search position="replace"><![CDATA[ 'pm' => array(]]>
</search>
<add><![CDATA[ 'ad_manage' => array(
'ad_manageperm' => false,
),
'pm' => array(]]>
</add>
</operation>
</file>


I didn't install manually and I have exactly the same problem.

The ads are all set up but only visible in the places they are supposed to be, when logged in as Admin.

Help appreciated please, as I don't follow what your code snippet is telling me I need to do.

Many thanks.
Title: Re: Ads only show up to Admin,not guest or members
Post by: elragal_30 on April 04, 2007, 04:57:03 pm
hii all
what is the joke ?? :D
i register here because i have the same problem
but now i know how to solve it very easy with no editing to any file
to make it view to Guests follow this steps :
Login at your ADMIN panel  
under Member section click (Permissions)
you will see Groups names
next to Guests press (Modify)
at the top you will see ( Enable Ads) chek it to make ads viwable by Guests

do the same for other groups like members ,adminstrators ,group

Notice  : if you don't see  (Enable ads) Go to (Permissions)
next to (ADD Permissions's menu) open the menu choose ( Enable Ads) ---> click ( set permissions)
thanks
Title: Re: Ads only show up to Admin,not guest or members
Post by: bigguy on April 09, 2007, 08:58:50 pm
No joke here, someone had permissions problems that could only be solved by adding or checking code, but thanks for the guide on how to enable permissions. ;)
Title: Re: Ads only show up to Admin,not guest or members
Post by: cincinati on April 11, 2007, 01:28:28 am
hii all
what is the joke ?? :D
i register here because i have the same problem
but now i know how to solve it very easy with no editing to any file
to make it view to Guests follow this steps :
Login at your ADMIN panel  
under Member section click (Permissions)
you will see Groups names
next to Guests press (Modify)
at the top you will see ( Enable Ads) chek it to make ads viwable by Guests

do the same for other groups like members ,adminstrators ,group

Notice  : if you don't see  (Enable ads) Go to (Permissions)
next to (ADD Permissions's menu) open the menu choose ( Enable Ads) ---> click ( set permissions)
thanks


THANKS MATE THAT WAS REALLY HELPFULL
Title: Re: Ads only show up to Admin,not guest or members
Post by: Velvet on April 19, 2007, 05:55:50 am
hii all
what is the joke ?? :D
i register here because i have the same problem
but now i know how to solve it very easy with no editing to any file
to make it view to Guests follow this steps :
Login at your ADMIN panel  
under Member section click (Permissions)
you will see Groups names
next to Guests press (Modify)
at the top you will see ( Enable Ads) chek it to make ads viwable by Guests


Thank You!  Thank YOU! 

Boy do I have alot to learn with SMF or what?  This was really stumping me.  Is all this explained in the manual?


Thanks again pal - you've made my day today!
Title: Re: Ads only show up to Admin,not guest or members
Post by: dtarver on April 25, 2007, 08:29:56 pm
... i know how to solve it very easy with no editing to any file
to make it view to Guests follow this steps :
Login at your ADMIN panel  
under Member section click (Permissions)
you will see Groups names
next to Guests press (Modify)
at the top you will see ( Enable Ads) chek it to make ads viwable by Guests

do the same for other groups like members ,adminstrators ,group

Notice  : if you don't see  (Enable ads) Go to (Permissions)
next to (ADD Permissions's menu) open the menu choose ( Enable Ads) ---> click ( set permissions)
thanks

THANK YOU!!!  :-*  I was having an issue not seeing ads too.  I recommend they change the install program to "enable ads" since that is why we install it. ~Thanks again!
Title: Re: Ads only show up to Admin,not guest or members
Post by: cbmr777 on June 06, 2007, 05:32:40 pm
Quote
... i know how to solve it very easy with no editing to any file
to make it view to Guests follow this steps :
Login at your ADMIN panel
under Member section click (Permissions)
you will see Groups names
next to Guests press (Modify)
at the top you will see ( Enable Ads) chek it to make ads viwable by Guests

do the same for other groups like members ,adminstrators ,group

Notice : if you don't see (Enable ads) Go to (Permissions)
next to (ADD Permissions's menu) open the menu choose ( Enable Ads) ---> click ( set permissions)
thanks

I have to add a HUGE thank you to this as well!  I couldn't for the life of me figure out why *I* could see the ads and no one else could!  This has fixed the problem for my forum as well!

Perhaps this could be in the readme installation file?  :)

Title: Re: Ads only show up to Admin,not guest or members
Post by: elragal_30 on June 21, 2007, 12:38:29 pm
No joke here, someone had permissions problems that could only be solved by adding or checking code, but thanks for the guide on how to enable permissions. ;)
sorry for this i don't want to  cheat here 
i was mean that it is fuuny thing that i have face this problem and ask some and can't solve (at this time)
then  after i register here
i found the answer whil i setup another mod and go to permission page and see option "enaple ads"
so i know how to make that
so i talk about that after i register here to find who solve this problem  , i solve it to other (i'm happy for that )
sorry again
thanks to all thanks me (no thanks i just want to help )

see my suggestion (http://www.smfads.com/forums/index.php?topic=928.0)
+**********
*but now i have problem with some kinds of ads ( ex: at  the top on every page , *after user info , ...etc ) but other  (ex : between posts,child forums, at some *forum,..etc) working with some themes
*so i want to know how i can make it work at all themes ( and when i install new *theme it work on it ) ??
*have i evry time must edit theme's file or there are another way ???
*
*Notice :
*i setup the mod form package ( upload it -----> apply -----> install * )  
*
****************************************
Title: Re: Ads only show up to Admin,not guest or members
Post by: kyoko on July 08, 2007, 09:37:59 pm
Hey! thanks a lot! this solves the matter!!!  ;D