SMF Ads Support Forum

Support => General Support => Topic started by: jaysteele on November 30, 2006, 06:57:43 pm

Title: package installed - Ad Management link not there
Post by: jaysteele on November 30, 2006, 06:57:43 pm
I successfully installed the package but the Ad Management link is not showing up under the configuration menu. Using Babylon theme. Please advise as to what is wrong. Thanks.

Jay
Title: Re: package installed - Ad Management link not there
Post by: jerm on November 30, 2006, 08:39:08 pm
Version of the mod you are using?
Title: Re: package installed - Ad Management link not there
Post by: jaysteele on November 30, 2006, 08:47:16 pm
version 2.0
Title: Re: package installed - Ad Management link not there
Post by: bigguy on December 03, 2006, 11:31:35 am
Check the modifications.english.php file and see if the edits were done to that file.
Title: Re: package installed - Ad Management link not there
Post by: Bates on June 19, 2007, 01:40:04 pm
I have the same problem. I checked the necessary tables.. they exist. You say to check modified.english.php? I don't have that file...

Can you please explain more to me?

I'm using the Blublur theme
Title: Re: package installed - Ad Management link not there
Post by: bigguy on June 20, 2007, 05:11:00 pm
Move the modifications.english.php file from the default language folder to the language folder of the theme you use. If there is no language folder create one and put the modifications.english.php file into it.
Title: Re: package installed - Ad Management link not there
Post by: Bates on June 21, 2007, 05:22:11 am
Thanks that worked..

I also tried to modify the theme for use with these ads but euhm.. I get double ads published  :( Which means I have 2 banners from google adsense. Also after the modification some topic replies are simply gone ! Some are, others are not... very strange...

I put the original theme files back and then the posts are back but ofcourse no ads then.. any help?
Title: Re: package installed - Ad Management link not there
Post by: bigguy on June 24, 2007, 10:46:46 am
go throught the 4 template files and see if there is any duplicate code and remove it.
Title: Re: package installed - Ad Management link not there
Post by: ]-[iigara[KS] on June 25, 2007, 03:54:13 am
Hello, I'm having this same problem but moving the modifications.english.php file didn't fix it.  Any other ideas?  aa_damage is the theme I use, but I get the same problem even when using the default theme.  I have version 2.3

Hmm, very strange.  I tried installing it last night but ran into a bunch of forum problems, so I gave up on it and ended up reinstalling my forums.  So I'm still on the default theme right now, haven't tried putting the aa_damage theme back up yet, but oddly before I did notice it changed the modifications.english.php file by adding a couple lines (don't remember what, i know little PHP), but now there's no change when I try installing it.  The tables also were not created this time  :-\

Err scratch that last bit, they're there now .. but still no change to modifications.english file, and the link still isn't showing up.  Like I said I'm using version 2.3.  Modifications.english.php isn't one of the files listed on the install page.  Does that not matter or do I have a different issue?

Thanks
Title: Re: package installed - Ad Management link not there
Post by: bigguy on June 25, 2007, 07:36:25 am
Add the edits to that file and make sure there is a copy of it in the theme directory of the theme you are using.
Title: Re: package installed - Ad Management link not there
Post by: clownpoop on July 09, 2007, 03:14:40 am
Move the modifications.english.php file from the default language folder to the language folder of the theme you use. If there is no language folder create one and put the modifications.english.php file into it.

hi I don't have the file modifications.english.php

Add the edits to that file and make sure there is a copy of it in the theme directory of the theme you are using.
what edits? can you explain to me more? pls help
Title: Re: package installed - Ad Management link not there
Post by: tonilah on July 09, 2007, 02:02:15 pm
my link won't show either

here is in what's my modifications.english file.  I am using the default theme, and the newest version of SMF and ad mod.

Quote
<?php
// Version: 1.1; Modifications

?>
Title: Re: package installed - Ad Management link not there
Post by: clownpoop on July 09, 2007, 11:47:14 pm
hi, what do you mean by
Add the edits to that file and make sure there is a copy of it in the theme directory of the theme you are using.

here's what that file contains
Quote
<?php
// Version: 1.1; Modifications


$txt['MemberColorLinkHeadline'] = 'Member Color Link';
$txt['MemberColorLink'] = 'The display of the threadindex';
$txt['MemberColorThreadOwner'] = 'The thread owner at the boardindex';
$txt['MemberColorThreadLastPost'] = 'The last post member at the messageindex';
$txt['MemberColorThreadChild'] = 'The last post member at the childboard';
$txt['MemberColorBoardindex'] = 'The last post member at the boardindex';
$txt['MemberColorBirthday'] = 'The Birthday Links of the Members (Calendar and Boardindex)';
$txt['MemberColorRecentOwner'] = 'Recent posts, threadowner';
$txt['MemberColorRecentLastPost'] = 'Recent posts, the last poster';
$txt['MemberColorInbox'] = 'Change colors in the Instant Messages Inbox';
$txt['MemberColorOutbox'] = 'Change colors in the Instant Messages Outbox';
$txt['MemberColorLatestMember'] = 'Color the Latest Member';
$txt['MemberColorStats'] = 'Change color in the Boardstats.';
$txt['MemberColorWhoIsOnline'] = 'Color the Who is Online (Messagesindex and Threadindex)';
$txt['MemberColorGuests'] = 'Color for Guest nicknames<br /><span class="smalltext">Boradindex, Messageindex and Theaddisplay</span>';

$txt['MemberColorLinkHeadline'] = 'Member Color Link';
$txt['MemberColorLink'] = 'The display of the threadindex';
$txt['MemberColorThreadOwner'] = 'The thread owner at the boardindex';
$txt['MemberColorThreadLastPost'] = 'The last post member at the messageindex';
$txt['MemberColorThreadChild'] = 'The last post member at the childboard';
$txt['MemberColorBoardindex'] = 'The last post member at the boardindex';
$txt['MemberColorBirthday'] = 'The Birthday Links of the Members (Calendar and Boardindex)';
$txt['MemberColorRecentOwner'] = 'Recent posts, threadowner';
$txt['MemberColorRecentLastPost'] = 'Recent posts, the last poster';
$txt['MemberColorInbox'] = 'Change colors in the Instant Messages Inbox';
$txt['MemberColorOutbox'] = 'Change colors in the Instant Messages Outbox';
$txt['MemberColorLatestMember'] = 'Color the Latest Member';
$txt['MemberColorStats'] = 'Change color in the Boardstats.';
$txt['MemberColorWhoIsOnline'] = 'Color the Who is Online (Messagesindex and Threadindex)';
$txt['MemberColorGuests'] = 'Color for Guest nicknames<br /><span class="smalltext">Boradindex, Messageindex and Theaddisplay</span>';
?>
Title: Re: package installed - Ad Management link not there
Post by: tonilah on July 10, 2007, 02:57:50 pm
i think for some reason my modifications.english.php wasn't edited for the ads module.  I opened up the last version of the ads mod and took a peek at the install.xml.  and added this to my modifications.english.php file. 

Quote
// Js - Strings

$txt['js_ads_title'] = 'Ad Management';
$txt['js_text_displayads_index'] = 'Display ads on every page (ontop)';
$txt['js_text_displayads_botindex'] = 'Display ads on every page (onbottom)';
$txt['js_text_displayads_board_index'] = 'Display ads on Board Index';
$txt['js_text_displayads_display'] = 'Display ads on Thread';
$txt['js_text_displayads_message_index'] = 'Display ads on Thread Index';
$txt['js_text_displayads_firstpost'] = 'Display ads after first post';
$txt['js_text_disc'] = 'Write your code here';
$txt['js_text_help'] = 'Make sure that your code is compatible with HTML';
$txt['permissiongroup_ad_manage'] = 'Ad Management';
$txt['permissionname_ad_manageperm'] = 'Enable ads';
$txt['permissionhelp_ad_manageperm'] = 'To enable ads to appear for this membergroup, this must be checked';

that cleared things up!  make sure you have your language set on english too, mine was set on english ut8 by default.
Title: Re: package installed - Ad Management link not there
Post by: clownpoop on July 11, 2007, 12:41:06 am
I know nothing of php :'( I just put the your code to my modification.english.php file but it still don't work
Title: Re: package installed - Ad Management link not there
Post by: torque on July 13, 2007, 12:19:22 pm
Hi, you need Ads.english-utf8.php to be copied into the languages directory, instead of the Ads.english.php that comes with the current version.  You can simply hand copy Ads.english.php to Ads.english-utf8.php, or, alternatively, use my hacked Ad Management installer (http://torque.gig8.com/2007/07/resolving_the_missing_ad_management_link_smf_113.html).  Details in post.  The only change is addition of the -utf8 file and a mod to the package-info.xml file.  Hopeful smfads will do a modified release soon.