SMF Ads Support Forum

Themes/Language => Theme Support => Topic started by: Tomboss on November 16, 2009, 08:34:25 am

Title: SMF 2.0 RC2 Incorrect information for manual installation
Post by: Tomboss on November 16, 2009, 08:34:25 am
Hello,

I try to manually install the mod in the last version of SMF (2.0 RC2) by following the instructions on this page (http://custom.simplemachines.org/mods/index.php?mod=255) (Manual install instructions ==> 2.0 RC2).

Unfortunately I encounter some problems :( .

In the / Themes / default / index.template.php, the following lines are missing:


Find:
Code: [Select]
<div class="windowbg2 clearfix">';
Replace With:
Code: [Select]
<div class="windowbg2 clearfix floatleft">';
Find:
Code: [Select]
<form class="windowbg" id="guest_form" action="', $scripturl, '?action=login2" method="post" accept-charset="', $context['character_set'], '" ', empty($context['disable_login_hashing']) ? ' onsubmit="hashLoginPassword(this, \'' . $context['session_id'] . '\');"' : '', '>
Replace With:
Code: [Select]
<form class="windowbg2" id="guest_form" action="', $scripturl, '?action=login2" method="post" accept-charset="', $context['character_set'], '" ', empty($context['disable_login_hashing']) ? ' onsubmit="hashLoginPassword(this, \'' . $context['session_id'] . '\');"' : '', '>

In the /Themes/default/MessageIndex.template.php, the following lines are missing:

Find:
Code: [Select]
echo '
</table>
</div>';

Add After:
Code: [Select]
//Display Ads on the Message index
if (function_exists("show_underchildren"))
{
$ads = show_underchildren();
if(!empty($ads))
if($ads['type']==0)
echo $ads['content'];
else
eval($ads['content']);
unset($ads);
}

   
Everything else is correct.

Does someone could help me?

Thank you ;)